Understanding and Configuring PPP Multilink

PPP


In a network design, we frequently see more than one serial link between two routers. Perhaps a single serial link is insufficiently bandwidth-rich, or you require additional redundancy. Because each interface on a router requires a unique IP address, a design with two serial links is possible.

Multilink PPP (Point-to-Point Protocol) is used to combine or aggregate multiple PPP physical links into a single logical bundle or virtual link for greater bandwidth.

This post explains PPP Multilink in-depth and shows how to set up a Cisco router to use it between two serial ports.

PPP enables network traffic to be transmitted over point-to-point connections. Point-to-point links include ISDN and synchronous serial links. PPP is also described in RFC1661. PPP Multilink is used to 'bond' multiple PPP links together, causing them to behave as if they were a single PPP link. 

PPP Service providers that join numerous links for a customer in order to give more capacity are good examples of multilink.

We will go over the commands you will need for the configuration, as well as how to check that the PPP Multilink is working properly.

A company, for example, can order two S1 connections from their service provider, each with a speed of 2.048Mbits/sec. We may merge these two links into one using PPP Multilink, resulting in a single link with a speed of 4.096Mbit/sec.

It is crucial to note that PPP Multilink requires an identical configuration on both ends, which means that the link will not work unless both you and your ISP have PPP Multilink configured.

How does PPP Multilink function?

The Multilink PPP functionality distributes the load across multiple WAN links for both incoming and outgoing traffic. It also provides load calculation, appropriate sequencing, packet fragmentation, and multivendor interoperability.

The Multilink PPP feature supports both fragmentation and packet sequencing specifications in RFC 1990

Using Multilink PPP, packets can be fragmented, split, and can be sent at the same time over the same remote address over multiple PPP channels. Multiple links appear in response to a dialer load threshold. As appropriate, the load can be estimated for both inbound and outbound traffic between specific sites. 

Multilink PPP enables on-demand bandwidth and lowers WAN transmission latency. Multilink PPP supports dial-on-demand rotary groups as well as PPP encapsulation across synchronous and asynchronous serial interfaces.

PPP Bundles with Multiple Links

Multilink PPP is a protocol that combines multiple physical links into a logical bundle known as a Multilink PPP bundle. A Multilink PPP bundle consists of a single virtual interface that connects to a peer system. 

Traffic flows from a single point can be subjected to shaping, policing, and hierarchical queueing using a Multilink PPP bundle interface or a single interface. Individual links within a bundle do not use hierarchical queueing. None of the links are aware of the traffic on the parallel links.

PPP Bundles with Multiple Links and PPP Links

PPP interfaces that are fully functional are required for Multilink PPP to function. Multiple links can connect peer devices in a Multilink PPP bundle. These connections can be either serial or broadband (Ethernet or ATM). In a bundle, combined links work properly as long as each link acts like a standard serial interface.

Configuring a link to a specific bundle requires the use of the PPP multilink group command. This command limits the link to only joining the specified bundle. When a link joins a Multilink PPP bundle, it must offer the right identification of the Multilink PPP bundle. The link is assigned to the requested Multilink PPP bundle If the negotiation process is successful.

If the link fails to match the identity of a Multilink PPP bundle that is already active on the multilink group interface or the link's identification matches that of another Multilink PPP bundle, the connection is terminated.

A link can join a Multilink PPP bundle only if the exchanged identification matches that of an existing bundle.

When you run the Point to Point multilink group command on a specific link, it imposes the restrictions as listed below.

  • The link can not join any other bundle if the bundle is specified by the group interface.
  • If the peer device attempts to join a different bundle, the multilink PPP session must be terminated.

Multilink PPP Bundle Interface Types

  • Interfaces for multilink groups
  • Interfaces for virtual access (VAIs)

Once a bundle is established, these interfaces provide the same level of functionality (multilink and PPP). On a bundle, all PPP and multilink-related features operate in the same way.

What exactly are PPP and Mlppp?

Multi-link PPP (MLPPP) has been introduced which bundles multiple links into one logical pipe. An MLPPP connection can have additional PPP links added to it without disrupting service. Each PPP link has access to the combined bandwidth of all links when using Multi-link PPP.

PPP Command

To specify PPP as the encapsulation method for a serial interface, use the interface configuration command "encapsulation PPP". The encapsulation PPP interface command takes no arguments.

Most common authentication protocols are used with PPP

The PAP, the CHAP, and the Extensible Authentication Protocol (EAP) are all PPP authentication mechanisms. In all of these cases, the peer device is authenticated rather than the device's user.

Which is better, PAP (Password Authentication Protocol) or CHAP ( Challenge Handshake Protocol)?

CHAP is a more secure method of authentication than PAP. The secret is not transmitted over the link in CHAP, and it protects against repeated attacks during the lifetime of the link. CHAP is an encrypted authentication scheme that does not send the unencrypted password over the network. 

As a result, if both CHAP and PAP authentication are enabled, CHAP authentication is always used first.

Configuring PPP Multilink

Configuring PPP Multilink is a fairly simple process; however, configuration steps may differ depending on the interfaces and protocols involved.

In our example, two serial interfaces installed on our customer's router must be bonded with service provider links. The customer has, of course, previously requested that the two serial lines support PPP Multilink.

Assigned IP address to interfaces

R1#conf t

R1(config)#int f1/0

R1(config-if)#ip address 192.168.10.254 255.255.255.0

R1(config-if)#no shut


R1(config)#int s5/0

R1(config-if)#no shut

R1(config-if)#int s5/1

R1(config-if)#no shut


R1(config)#int multilink 1

R1(config-if)#ip address 12.1.1.2 255.255.255.252 

R1(config-if)#no shut

R1(config-if)#exit

R1(config)#int s5/0

R1(config-if)#encapsulation PPP

R1(config-if)#ppp multilink group 1

R1(config-if)#int s5/1

R1(config-if)#encapsulation PPP

R1(config-if)#ppp multilink group 1


RIP Configuration for connectivity between both routers -R1&R2

R2#conf t

R2(config)#router rip 

R2(config-router)#version 2

R2(config-router)#network 12.1.1.0

R2(config-router)#network 192.168.10.0


R2#conf t

R2(config)#int f1/0

R2(config-if)#ip address 192.168.20.254 255.255.255.0

R2(config-if)#no shut

R2(config)#int s5/0

R2(config-if)#no shut

R2(config-if)#int s5/1

R2(config-if)#no shut


R2(config)#int multilink 1

R2(config-if)#ip address 12.1.1.2 255.255.255.252 

R2(config-if)#no shut

R2(config-if)#exit

R2(config)#int s5/0

R2(config-if)#encapsulation ppp

R2(config-if)#ppp multilink group 1

R2(config-if)#int s5/1

R2(config-if)#encapsulation ppp

R2(config-if)#ppp multilink group 1


RIP Configuration for connectivity between both routers -R1&R2

R2#conf t

R2(config)#router rip 

R2(config-router)#version 2

R2(config-router)#network 12.1.1.0

R2(config-router)#network 192.168.20.0

Verifying Configuration

Before configuring Multilink, the total bandwidth 1544



After Multilink configuration


The output indicates that everything is working properly and that the bandwidth has been doubled: 3088

Article Summary 

In this article, we discussed how to configure PPP Multilink on a Cisco router. We covered the commands required to ensure that the selected serial interfaces are included in the Multilink bundle and that the Multilink interface is operational.



0 Comments: